SMC Discussion Areas
August 19, 2022, 09:32:53 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: New guy with first machine Cavalier CS64-ES  (Read 252 times)
0 Members and 1 Guest are viewing this topic.
TXNathan18
Newbie
*
Offline Offline

Posts: 1


« on: March 10, 2022, 01:47:05 pm »

Hi all,

Thank you for allowing me to join, I have been reading posts for a while and not found answers to a few questions. I just got my first machine and its a square top Cavalier CS64-ES.  I plugged it in and the fans run but no compressor.  I removed the compressor system (Deck?) to inspect and test.  It had to come out anyway because of the amount of rust on the floor.  I pulled the plug off the three pins and nothing is shorted so I think I can proceed on the testing.  I am unsure what exactly I am seeing here and if I should add a capacitor of some kind.  I expected to find one there but there isn't one.

Can someone confirm that what I am seeing is an old start relay and perhaps a thermal overload switch?

There is a fair amount of rust on the lower fins and tube for the radiator (Condenser?) that is with the compressor.  I think its all copper so the rust is probably just there from the base it was mounted on.

What is the safest way to clean that off without damaging it? 

Thanks for the site and any help,

Nathan
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.15 | SMF © 2011, Simple Machines Valid XHTML 1.0! Valid CSS!